Beaumont Middle School Design Project
April – May 2014
Carl Lee and Craig Schroeder
SketchUp

1. SketchUp is free, and you can download it from the website www.sketchup.com. For some K12 use, see www.sketchup.com/3Dfor/k12-education.

2. For some student work from Jessie Clark Middle School in Lexington, see www.ms.uky.edu/~lee/jessieclark/jessieclark.html. Some mathematics lesson at various grade levels using SketchUp are here: http://www.3dvinci.net.

3. To see videos on how to use Google SketchUp, go to the website www.sketchup.com/learn.
Eight Grade Project - Jessie Clark Middle School
http://www.ms.uky.edu/~lee/jessieclark/room1.skp
Introduction to SketchUp

Basic Concepts

1. Start up SketchUp and Select View → Tool Palettes → Large Tool Set to display the large tool set.

2. Orbit tool. Change direction of view. You can also do this by pressing and holding the mouse scroll wheel.

3. Zoom tool. Change distance of view. You can also do this by rolling the mouse scroll wheel.

4. Pan tool. Slide the view around. You can also do this by pressing and holding the mouse scroll wheel while also holding the Shift key.

5. Zoom Extents tool. Click on this tool to frame your entire scene.

6. Select tool. Use this to select objects. For example, you can click on an object (like the initial human figure) and press delete to remove it. Double click on a shape to pick up its boundary as well. Triple click on a shape to pick up everything connected to it. To select a collection of objects you can click and drag a frame around what you want to choose, or you can hold the Shift key down while clicking on various objects.

7. Rectangle tool. Draw rectangles. Click to start, move mouse to draw, click to finish.
   - As you are drawing, watch the dimensions of the rectangle in the lower right hand corner of the screen. These dimensions show up for other objects as well.
   - A message and a diagonal appears when your rectangle happens to be a square or a golden rectangle.
   - After drawing you can type, for example, 5’,6’ and press Enter to get a rectangle that is 5 feet by 6 feet.

8. Line tool. Draw sequences of line segments. Click to start, move mouse to draw, click to complete one line segment and start another, press Esc to finish your sequence of line segments.
   - As you are drawing them, line segments are colored red, green, or blue if they are parallel to the axes.
   - After drawing a line segment you can type, for example, 10’ and press Enter to get a line segment of that length.
   - You need a closed simple polygon for SketchUp to make a shape.
9. Push/Pull tool. Once you have a closed shape, you can push or pull it into three dimensions. Click to start, move mouse to draw, click to finish.
   • After dragging you can type, for example, 4’ and press Enter to achieve a motion of that length.
   • When you have created some three-dimensional objects, you can draw new lines and shapes on their faces, and then push or pull them as well.
   • When you pull polygons you get right prisms.
   • When you pull circles you get cylinders.

10. Circle tool. Draw circles. Click to mark the center, then click to mark a point on the circle.
    • As you are drawing them, circles are colored red, green, or blue if they are perpendicular to the axes.
    • After dragging you can type, for example, 6’2” and press Enter to get a circle of that radius.
    • Before clicking the center of the circle, move the “ghost circle” around the scene until it is the desired color (orientation). Then hold the Shift key down to maintain that color, moving the circle to the desired location of its center.

11. Polygon tool. Draw regular polygons. For example, to draw a pentagon, click on the tool, type 5, press Enter, click on the location of the center of the polygon, and then click to mark a vertex.
    • As you are drawing them, polygons are colored red, green, or blue if they are perpendicular to the axes, and radii of polygons are colored red, green, or blue if they are parallel to the axes.
    • After dragging you can type, for example, 3’5” and press Enter to get a polygon of that radius.
    • Before clicking the center of the polygon, move the “ghost polygon” around the scene until it is the desired color (orientation). Then hold the Shift key down to maintain that color, moving the polygon to the desired location of its center.

12. Paint Bucket. Use this to choose textures for your shapes. You can even make them translucent. Experiment!

13. Window ➔ Shadows. Turn shadows on and off, and set the time of day. You can also set your location by Window ➔ Model Info ➔ Geo-location.

14. Move tool. First choose the Select tool. Click on a line segment, or double click on a surface, or triple click on a solid. Select the Move tool. Click on a point and then move mouse to move the object somewhere else, and click to finish. After moving you can type, for example, 5’ and press Enter to move the selection that distance. Tip: use a particular point of the object, like a corner.
Challenge #1

Make your own “still life” with a cube, a rectangular prism, a pentagonal prism, a prism with a base that is not a regular polygon, and a cylinder.
Drawing Shapes

1. Create a closed loop of edges to make a surface. The edges in the loop must be coplanar. SketchUp snaps to the Red, Green and Blue axes. Watch the edge colors as you draw.

2. Watch the axis directions and use inferring to line up edges. Inferring is done by hovering over key points for two seconds.

3. Learn and use the different inference points. Endpoints are shown with green dots. Midpoints are shown with cyan dots. Where two edges cross is shown with a black dot.
Challenge #2

Construct a 4’ x 4’ cube with a cylindrical hole having radius 1.5’. What is its volume?
Challenge #3

Make your own “Giant’s Causeway” (or make a different sketch based on tilings by polygons). Suggestion: Make the polygons of particular sizes in advance, and then move them to the desired locations.

Giant’s Causeway in Northern Ireland
http://simonward.com/wallpaper/causeway.jpg
Challenge #4

Sketch an octahedron – a polyhedron composed of 8 equilateral triangles. Suggestion: First draw line segments from the origin to each of the six vertices.

Challenge #5

Construct a partial Sierpinski triangle. Suggestion: Make an initial triangle. Choose the Select tool and click on the boundary. Then right click on the boundary and choose “Explode Curve”. Even though you might not notice the effect, this breaks up the boundary into three separate line segments.
Some More Drawing Tools

1. Arc tool. Draws an arc. Click to mark the center, click to start the arc, and click to end the arc.

Using the Push/Pull Tool

1. The Push/Pull tool works on any flat shape. It can be used to pull out or push in that shape perpendicular to the surface.

2. To push or pull an accurate amount:
   - Begin the action (push or pull).
   - Type in a value, such as 5’3” or 10cm or 6m.
   - Press the Enter key.

3. You can also push or pull an accurate amount by inferring to another surface.
   - Click and drag to start moving one surface.
   - Then move the cursor over to another surface and release to finish.
   - You can infer across and through other surfaces. You can infer to any edge or surface you can see on the screen.

4. To make holes or openings through an object, or shave off portions:
   - Draw shapes on one surface.
   - Push them back to a parallel surface (you can use inferring to tell when to stop upon reaching a back edge or face).
   - Both surfaces must be parallel and clear of edges that might be in the way.
Using the Move Tool

1. You can move:
   - Endpoints
   - Edges
   - Surfaces
   - Selected Entities
   - Grouped Objects

2. Using the tool.
   - First use the Select tool to select what you want to move.
   - Then use the Move tool to click and drag. For accuracy in placement, click on a particular point (like an endpoint or a midpoint) and drag it to another particular point. Also, after dragging you can type, for example, 6’ and press Enter to move the selection that particular amount.
   - Moving edges is one way to create slanted surfaces.
   - Unselected objects attached to the selected objects may stretch or deform. If you want to avoid this, after selecting what you want to move, point to the selection, right click, and choose “Make Group”. Now move it. When you are done, you can select it again, right click, and choose “Explode”. This breaks the group up into individual independent pieces again.
   - Hold down the Alt key for Auto-fold.

3. Copying. Hold the Control key down while moving, to create and move a copy of your selection.
   - If you use first use “Make Component” instead of “Make Group” (you can right click or use the tool for this), your copy will be a clone of the original. Subsequent changes in the original (double click it to edit the component) will occur in the copy or copies also.

4. Making an array of copies. Hold the Control key down while moving, to create a copy of your selection. Then type, for example, 5x and press Enter to create 5 copies in a row, extending beyond the first copy. You can also type, for example, 5/ and press Enter to create 5 copies between the original selection up to and including the first copy.
Challenge #6
Challenge #7

Use copy with array to make a set of bins. Then delete pieces to make a maze.

Try walking through this using the Walk tool!
The Rotate Tool

1. Using the tool.
   • First use the Select tool to select what you want to move.
   • Then choose the Rotate tool. A ‘protractor’ will appear. Click on a point to mark the center of the rotation. For example, you could choose the origin, or some other particular point in the scene. Note the color of the protractor – the color will indicate whether it is perpendicular to the Red, Green, or Blue axes. Move the cursor away from the center and click to make a “lever arm”. Now move the cursor to perform the rotation. Click when you are done.
   • At this point you can type, for example, 30 and press Enter to get a rotation of exactly 30 degrees.
   • Suggestion: You may have to change your viewpoint of the scene first to get a protractor of the desired color – try “looking along” the axis you are interested in. Once it is the desired color, or orientation, you can hold the Shift key down to maintain that orientation.
   • Unselected objects attached to the selected objects may stretch or deform. If you want to avoid this, after selecting what you want to rotate, point to the selection, right click, and choose “Make Group”. Now rotate it. When you are done, you can select it again, right click, and choose “Explode”. This breaks the group up into individual independent pieces again.
   • To choose a particular line segment to be the axis of rotation after you have selected the Rotate tool, click one endpoint and drag to the other endpoint.

5. Copying. Hold the Control key down while rotating, to create and rotate a copy of your selection.

6. Making an array of rotated copies. Hold the Control key down while rotating, to create a rotated copy of your selection. Then type, for example, 5x and press Enter to create 5 copies in an arc, extending beyond the first copy. You can also type, for example, 5/ and press Enter to create 5 copies between the original selection up to and including the first copy.
Challenge #8
Challenge #9

Make a cube. Double click on a face. Right click and make a group. Then use the rotate tool to start unfolding that face. Repeat (carefully)…
Challenge 10

Make an icosahedron by first constructing a set of three mutually-perpendicular golden rectangles.
Challenge 11

Make a tessellation by modifying a rectangle, triangle, or other shape.

Note: You can choose Camera ➔ Standard Views ➔ Top and Camera ➔ Parallel Projection to look down on the xy-plane from above. The Line and Circle Tools then enable you to make standard “straightedge and compass” constructions.
Using the Follow Me Tool

1. With this tool you can cause a shape to follow (extrude) along a path.
   • First draw a path – it can be, for example, a path of line segments, or a circle, or a freehand curve.
   • Now draw the shape that you wish to follow the path. It helps to construct the shape to be perpendicular to the start of the path.
   • Use the Select tool to select the entire path.
   • Click the Follow Me tool.
   • Click on the shape.

2. You can use this tool to make spheres, for example – just cause a circle to spin around by following the boundary of another circle.

3. Construction Ideas: How can you make a cylinder? A cone? A torus?
Challenge #12

Construct a sphere. Use the boundary of a circle as a path, and another circle as the shape to follow the path.
Challenge #13
Challenge #14
Challenge #15

This is the Soma Cube puzzle. You can make the individual pieces out of cubes. Then select an entire piece, right click, and Make Group. After that you can move them around (carefully!) with the Move tool.

Other Construction Ideas: Demonstrate a dissection of a cube into three congruent pyramids. Into six congruent pyramids. Create some three-dimensional space-fillers, like truncated octahedral or rhombic dodecahedra.
Challenge #16

You can use the Scale Tool (see below) to scale the top of a rectangular prism to make this shape. Then you can select various pieces, right click, Make Group, and finally use the Rotate tool to unfold your shape.

Challenge #17

Create and unfold this shape in a non-overlapping way. (I haven’t tried to do this yet!)
Challenge #18

This shows that you can make a square hole through a cube that is precisely the right size to pass a second cube of the same size through the first cube! Getting the angles right is tricky. I made the first cube, then used the Rotate tool more than once to get the main diagonal aligned with the vertical axes. Then I made a square and used the Push/Pull tool to pull it through the first cube. Select everything, right click, and choose Intersect→Intersect Selected. Finally, select and delete the pieces you do not want to keep.
More…

Here are some brief summaries of some more (but not all!) features.

1. Warehouse. A public repository of premade models is available on the web. Go to File \(\rightarrow\) 3D Warehouse. You can fetch models and insert them into your own sketches. You can also post your own models there.

2. Scale Tool. Select a grip and use it to scale the selected objects. Hold the Control key down to scale about the center. Hold the Shift key down for uniform scaling.
   - Type in a particular scale factor for a desired scaling amount (type in \(-1\) to reflect).

3. Offset Tool. Offset selected edges in a plane.

4. Tape Measure Tool. Measure distances, with or without creating guide lines.
   - Pressing the Control key toggles whether or not guide lines will be created.
   - If you click one point and then another, you measure the distance between the two points and create a guide line between them. Type in a particular distance to create a guide line of a particular length.
   - If you click an edge and then click another location, you create a parallel guide line. Type in a particular distance to create a guide line a particular distance away.
   - If you click one point (don’t drag), move the tape to a different location, and then type \(<1',2',3'>\), you will get a guide line to a new point at those coordinates relative to the starting point. But if you type \([1',2',3']\), you will get a guide line to a new point at those coordinates relative to the origin.
   - Construction Idea: Use guide points with coordinates relative to the origin to construct an octahedron or a tetrahedron.

5. Section Plane. Draw section planes to expose interior details in the model. Sections planes can be moved and rotated to different positions.
Challenge 19

Intersect Faces. Right click a selection of objects. Then intersect faces will insert elements that are intersections of the various parts.
- Construction Idea: Construct the shape of intersection of two or three mutually perpendicular cylinders.

Challenge 20

Layers. Use Window → Layers to open a Layers window and create multiple layers. Once created, you can select which layers are to be visible. You can then right click selected entities and choose Entity Info to choose the layer in which they exist.

Scenes (and Animation). Use Window → Scenes to open a Scenes window. create multiple scenes. Scene tabs will be created. Click on a scene tab and manipulate your view of the model and which layers are to be visible. Select that
scene in the Scenes window, and click the Update Scene(s) icon. Repeat with other scenes. Then you can move from scene to scene by clicking on the desired scene tabs. At this point you can use View ➔ Animation ➔ Play to view the scenes sequentially.

9. Dimension Tool. Draw dimension lines (with labeled distances) between any two points.


11. Text Tool. Insert text labels.

12. Axes. Reposition the coordinate axes.

13. 3D Text Tool. Insert three-dimensional text.

14. Position Camera Tool. Position the camera view with a specific location, eye height and direction.

15. Look Around Tool. Pivot camera view about a stationary point.

16. Walk Tool. Walk with the camera.